Task data inconsistency
Incident Report for Unmand
Postmortem

A convenience decorator was implemented in the API to improve the typing in the Task update endpoint called by the job runner. While this was extensively used and tested for usage in endpoints called by the Portal web UI, it contained an implicit conversion of JSON keys to snake_case. This was not picked up in the existing pre-deployment tests as we lacked sufficient variety in the Task data keys for test scenarios.

We apologize for the impact to affected customers. We are now introducing more robust tests around the Task data lifecycle and Task resubmissions.

Posted Apr 22, 2023 - 08:39 AEST

Resolved
Between approximately 5PM AEST to 8:45AM on the 22nd of April, keys in the Task data were automatically being cast to snake case. This may disrupt the display of values in the Data tab for Task data and keys may need to be renamed in the Raw Data tab to be able to successfully resubmit a Task.
Posted Apr 21, 2023 - 17:00 AEST